MailChannels Errors
Incident Report for EZPZ Hosting
Resolved
This issue has since been resolved and outbound mail service has been fully restored.
Posted 13 days ago. May 09, 2019 - 10:37 BST
Investigating
It appears MailChannels are suffering an outage resulting in all outbound email being rejected. MailChannels engineers are aware of the issue and are currently working on a fix.
Posted 14 days ago. May 09, 2019 - 10:16 BST
This incident affected: UK Servers, US Servers, and India Servers.