Nyx Offline
Incident Report for EZPZ Hosting
Resolved
This incident has been resolved.
Posted May 22, 2016 - 11:45 BST
Investigating
We are currently investigating severe packetloss on Nyx. Further updates to follow.
Posted May 21, 2016 - 12:25 BST