UK Network Issue
Incident Report for EZPZ Hosting
Resolved
The issue was caused by a network problem at an upstream provider which has since been resolved.
Posted 2 months ago. Aug 05, 2019 - 19:56 BST
Investigating
We are aware of a network issue at our UK location. Onsite techs are currently working to resolve the problem.
Posted 2 months ago. Aug 05, 2019 - 18:22 BST
This incident affected: UK Servers.