Degraded Cloud Performance
Incident Report for EZPZ Hosting
Resolved
This incident has been resolved.
Posted Sep 07, 2019 - 14:11 BST
Monitoring
Some UK Cloud servers are experiencing degraded performance due to a disk rebuild currently being performed. This is expected to complete in around 24 hours.
Posted Sep 05, 2019 - 10:24 BST
This incident affected: UK Servers.