Datacenter Power Outage
Incident Report for EZPZ Hosting
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 08, 2019 - 21:30 BST
Identified
We are currently looking into a power issue affecting all servers in Rack W5 at our Telehouse North 2 location. We expect service to be offline for sometime as we believe two PDUs have failed and need to be replaced. We are at this stage hoping that the onsite engineers will have service restored by 20:45 BST.
Posted about 1 month ago. Sep 08, 2019 - 19:58 BST
This incident affected: UK Servers.