Hestia DDoS Attack
Incident Report for EZPZ Hosting
Resolved
This incident has been resolved.
Posted May 26, 2016 - 22:04 BST
Investigating
The attack has picked up and we're once again working on the issue.
Posted May 26, 2016 - 21:05 BST
Monitoring
The server is currently up and running and we're monitoring it closely.
Posted May 26, 2016 - 20:12 BST
Identified
This server is currently under a large DDoS attack. We're working to mitigate this as quickly as we can.
Posted May 26, 2016 - 18:45 BST