Helios DDoS Attack
Incident Report for EZPZ Hosting
Resolved
This incident has been resolved.
Posted over 3 years ago. May 26, 2016 - 22:04 BST
Investigating
This server is currently under a DDoS attack. We're working to mitigate this as quickly as we can.
Posted over 3 years ago. May 26, 2016 - 21:05 BST