Invoicing Error
Incident Report for EZPZ Hosting
Resolved
The cause of this issue has been found and resolved and corrected invoices were issued today.
Posted about 1 month ago. Sep 02, 2019 - 11:59 BST
Investigating
This morning several incorrect invoices were automatically sent by our system. To resolve this we've temporarily disabled the system calculating those invoices and have cancelled the few that were sent in error.

We apologize for any inconvenience and confusion caused.
Posted about 1 month ago. Sep 01, 2019 - 11:50 BST
This incident affected: Support and Billing.