Aphrodite Offline
Incident Report for EZPZ Hosting
Resolved
The issue has been resolved and now the server is able to communicate with the cPanel license server.
Posted May 11, 2016 - 13:22 BST
Investigating
Aphrodite is currently offline and the issue is being investigated, more information to follow.
Posted May 10, 2016 - 22:17 BST